decipher - Signature System Errors – Incident details

All systems operational

Signature System Errors

Resolved
Degraded performance
Started over 1 year agoLasted about 3 hours

Affected

Electronic Signature

Degraded performance from 4:17 PM to 7:05 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved and we will continue to monitor.

  • Update
    Update

    A fix was implemented and we are monitoring results.

  • Update
    Update

    The issue has been identified by our signature partner and a fix is being implemented.

  • Investigating
    Investigating

    We are currently experiencing elevated error rates with our signature partner with documents sent for signature not being accessible. Our signature partner is aware of the issue and is investigating. We will provide continued updates. Thanks for your patience.