decipher - Degraded Email Performance – Incident details

All systems operational

Degraded Email Performance

Resolved
Degraded performance
Started almost 3 years agoLasted 3 minutes

Affected

Email

Degraded performance from 4:17 PM to 4:19 PM

Updates
  • Resolved
    UTC
    Resolved

    The fix was implemented successfully and Email is back to normal.

  • Investigating
    UTC
    Investigating

    Our Email service provider is currently experiencing intermittent connection issues and users are experiencing 404 errors when attempting to send an email. The issue has been identified and a fix has been put in place. We are currently monitoring and will send a status update shortly.