decipher - Email performance is degraded – Incident details

All systems operational

Email performance is degraded

Resolved
Degraded performance
Started about 4 years agoLasted about 3 hours

Affected

Email

Degraded performance from 1:29 PM to 4:17 PM

Updates
  • Resolved
    Resolved

    The incident has been resolved

  • Update
    Update

    Outbound delivery has fully recovered. We are currently experiencing a delay as we catch up from the previous delivery issues.

  • Update
    Update

    We are continuing to work on a fix.

  • Update
    Update

    We continue to work on a fix and are still experiencing sending delays. All other services are fully operational.

  • Update
    Update

    We are continuing to work on this issue.

  • Update
    Update

    We are experiencing sending delays but are continuing to work on a fix.

  • Investigating
    Investigating

    We have identified an issue that is affecting email performance. We are working on a fix and will provide updates.