decipher - Decipher Status - Digital Signature Services Interrupted – Incident details
All systems operational
Decipher Status - Digital Signature Services Interrupted
Resolved
Major outage
Started over 5 years agoLasted about 1 hour
Affected
Electronic Signature
Major outage from 1:15 PM to 2:03 PM
Updates
Resolved
Resolved
The issue has been resolved.
Update
Update
They have identified the issue and are working on a fix.
Investigating
Investigating
Our digital signature partner is experiencing an outage at the moment, affecting signature services in Decipher. They are investigating the incident. We will post updates soon.