decipher - Signature Service Degraded – Incident details

All systems operational

Signature Service Degraded

Resolved
Degraded performance
Started over 1 year agoLasted about 3 hours

Affected

Electronic Signature

Degraded performance from 3:02 PM to 6:07 PM

Updates
  • Resolved
    Resolved

    This has been resolved and we will continue to monitor.

  • Update
    Update

    Our signature partner continues working on the issue. Documents are now accessible for signature but after signing, there are delays in obtaining the signed document and signature log. We will continue monitoring and post updates.

  • Investigating
    Investigating

    Our signature partner is currently experiencing issues and documents for signature are not accessible. They are investigating the issue. We are monitoring closely and will post updates regularly.