decipher - Copy of Chat Support Service Currently Down – Incident details

All systems operational

Copy of Chat Support Service Currently Down

Resolved
Operational
Started about 2 years agoLasted about 1 hour
Updates
  • Resolved
    Resolved

    Chat support is now back up and running. Thanks for your patience.

  • Investigating
    Investigating

    Our chat service is currently down. Our chat service provider is working on a fix. In the meantime, please send any requests to support@deciphercredit.com. Thank you for your patience. We will let you know as soon as the chat system is back up.