decipher - Degraded Email Performance – Incident details

All systems operational

Degraded Email Performance

Resolved
Degraded performance
Started over 3 years agoLasted 40 minutes

Affected

Email

Degraded performance from 9:00 PM to 9:39 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved. Our team will continue to monitor in case we see any further issues.

  • Update
    Update

    Our Email service provider implemented a fix. We are monitoring and will post an update as soon as the issue is fully resolved.

  • Investigating
    Investigating

    Our Email service provider is currently experiencing intermittent connection issues. They are working on the issue and we will be monitoring the status and will send updates. Thanks for your patience.