decipher - Electronic signature component down – Incident details

All systems operational

Electronic signature component down

Resolved
Major outage
Started almost 6 years agoLasted about 1 hour

Affected

Electronic Signature

Major outage from 12:13 PM to 1:01 PM

Updates
  • Resolved
    Resolved

    Signature services are now restored.

  • Investigating
    Investigating

    Our signature service provider reported a major outage in API services.